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Product Unpacking and Inspection

PRODUCT UNPACKING AND INSPECTION
Upon receipt of the product, perform the following unpacking and inspection procedures.

OTE:	N If damage to the shipping container is evident upon receipt, request the carrier to be present when the product 
is unpacked.

1.	 Carefully open the shipping package, follow any instructions that may be marked on the exterior. Remove all cushioning 
material surrounding the product and carefully lift the product from the package.

2.	 Save the package and all packing material for possible use in reshipment or storage.
3.	 Visually inspect the product and applicable accessories for any physical damage such as scratches, loose or broken parts or 

any other sign of damage that may have occurred during shipment.
OTE:	N If damage is found, request an inspection by the carrier’s agent within 48 hours of delivery and file a claim with the 

carrier. A claim for equipment damage in transit is the sole responsibility of the purchaser.

OVERVIEW
The Flo-Check® USB Hydraulic System Analyzer can be used as a stationary or portable tester for both industrial and mobile 
hydraulic system diagnostics, and analysis of the prognostic health of a hydraulic system. It features flow, pressure and 
temperature sensors that are monitored by a data acquisition module. The module records the operating parameters of the 
system and transfers them to a laptop via the USB port.
The custom software utility is a Windows®-based application. This intuitive software configures the displayed information 
into user-selected engineering units and provides realtime graphics with instantaneous readings and trends for all three 
measurement parameters. The software permits the data to be saved as a .csv file format, for use with a spreadsheet program.
The Hydraulic System Analyzer is powered through the USB port of a PC, which makes it easy to setup and is ideal for portable 
applications. Interfaced to the PC application, the Hydraulic System Analyzer offers a straightforward method of monitoring 
system parameters, complete with data acquisition.
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Specifications

SPECIFICATIONS

Material
Housing 6013-T351 Anodized aluminum
Turbine Rotor T416 Stainless steel
Rotor Supports 6061-T6 Aluminum
Seals Viton® standard; EPR optional
Ball Bearings 440 C Stainless steel
Hub Cones 6061-T6 Aluminum alloy
Temperature Probe T303 Stainless steel
Valve 12L14 Steel body with 303 SS seat
Spool/Sleeve 12L14 Steel
Straightening Sections 6061-T6 Aluminum
Ports SAE Straight thread O-ring boss, female, J1926/1; BSPP ISO1179

Magnetic Pick-up Body 12L14 Steel, electroless nickel plate
Nut 12L14 Steel, electroless nickel plate

Electronic Case Cold rolled steel, black zinc plate with clear seal
Table 1: Material specifications

Power
USB Power +5V DC (supplied through USB port of a PC)
USB Voltage Tolerance +4.6V DC min, +5.25V DC max
Current 100 mA, typ

Table 2: Power specifications

Environmental
Pressure Rating 6000 PSI (414 Bar) maximum with a 3:1 safety factor; capable of 10,000 PSI (689 Bar) transients
Operating Pressure <6000 PSI (414 Bar, 41.4 MPa, 420 kg/cm²); capable of 10,000 PSI (689 Bar) transients
Internal Burst Disc 7500 PSI DP
Pressure Drop See "Flow vs Pressure Drop Charts, ∆P Captured Using  

Loading Valves" on page 27
Fluid Temperature -40…300° F (-40…150° C)
Ambient Temperature +32…185° F (0…85° C)
Storage Temperature -40…185° F (-40…85° C)
Humidity 0…90%, non-condensing

Table 3: Environmental specifications

Performance

Flow Accuracy ±1% of reading @ 32 cSt
Repeatability ±0.2%

Pressure

Accuracy ±0.5% BFSL (Best Fit Straight Line)
Stability ±0.25% of full scale
Zero Offset ±2% of full scale
TC (Temperature Coefficent) Zero and TC Span ±1.5% of full scale
Response Time 0.2 milliseconds

Temperature
Absolute Error (over range of 0…185° F) ±2.7° F (±1.5° C)
Nonlinearity ±0.7° F (±0.4° C)
Repeatability ±0.2° F (±0.1° C)

Data Acquisition

Sample Rate 10 kHz

PC Screen Update/Record Rate
Flow 1 second (average 10K samples)
Temperature 1 second (average 10K samples)
Pressure 1 second (min, max, average 10K samples)

Table 4: Performance specifications
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Calibration

CALIBRATION
Testers are verified using 0.876 specific gravity, 150 SUS (32 cSt) Mobil / DTE 24 hydraulic oil. An optional 5 or 10 point 
calibration certificate, traceable to NIST, ISO 9001, is available from the factory. An optional 10 point calibration can be 
performed for increased accuracy.

Model Number Designations

Model Number Nominal Port Size Flow Rate
F7164 and F7165 SAE 12 or G 3/4 2.00…30.0 gpm (7.50…114 lpm)
F7160 and F7162 SAE 16 or G 1 3.00…85.0 gpm (15.0…321 lpm)
F7161 and F7163 SAE 24 or G 1-1/2 7.00…199.9 gpm (26.0…757 lpm)

Table 5: Model number designations

READ INSTRUCTIONS THOROUGHLY BEFORE INSTALLING THE TESTER. IF YOU HAVE ANY QUESTIONS REGARDING 
PRODUCT INSTALLATION OR MAINTENANCE, CALL YOUR LOCAL SUPPLIER OR THE FACTORY FOR MORE INFORMATION.

General Information
The power measurements are derived from the product of flow and pressure.
H.P. = GPM × PSI

1714

H.P. = liters/min × Bar
447.40

kW = liters/min × kg/cm²
611

H.P. = liters/min × kg/cm²
456.2

H.P. = liters/min × MPa
44.74

kW = liters/min × Bar
600

kW = liters/min × MPa
60

•	 Make all tests at the same operating temperature to provide consistency of results. A typical operating temperature for 
mobile machinery is 150° F (66° C).

•	 Testing is easier and faster if quick disconnect couplers are used to install the Flo-Check USB Hydraulic System Analyzer.

•	 For complete descriptions of the following basic hydraulic tests using the Flo-Check USB Hydraulic System Analyzer, see 
"Test Procedures" on page 18:

◊	 "Tee" Test
◊	 Inline System Test
◊	 Control Valve and Bi-directional Hydraulic Motor Test
◊	 Bi-Directional Cylinder Test
◊	 Hydrostatic Transmission Diagnostics

THE INFORMATION IN THIS MANUAL IS FOR GENERAL APPLICATION ONLY. FOLLOW ANY INFORMATION FURNISHED BY 
THE MANUFACTURER OF THE MACHINE’S HYDRAULIC COMPONENTS. SPECIFIC SYSTEMS MAY REQUIRE SPECIFIC  
TEST PROCEDURES.

•	 Do a preliminary check of the hydraulic system’s oil supply, pump speed, oil lines and cylinder rods, as well as an external 
leak check, prior to installing the Flo-Check USB Hydraulic System Analyzer.
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Installing the Software

INSTALLING THE SOFTWARE
1.	 Close all applications you have running on your computer.
2.	 Insert the Flo-Check USB Hydraulic System Analyzer CD into your CD drive or download the software from  

www.badgermeter.com. 
If you have the auto-run feature enabled on your computer, the installation instructions automatically display.

OTE:	N If auto-run is not enabled, use Windows Explorer to navigate to the root directory on the CD. Double-click the 
setup.exe file to begin the installation.

3.	 Follow the installation prompts to complete the installation.
4.	 After a successful installation, a message displays asking to restart the computer. Select Yes.
The installation creates two shortcuts on the computer; one on the desktop and the second in the Start > Programs > Flo-Tech 
Windows menu.

CONNECTING THE HYDRAULIC SYSTEM ANALYZER TO YOUR COMPUTER 
FOR THE FIRST TIME
The Flo-Check USB Hydraulic System Analyzer connects to your computer through a USB port. Use the cable that came with 
the unit or use any standard USB A Male to USB B Male cable. The initial connection is easy and uses standard drivers within 
Windows that do not require special driver installation. 

•	 The Hydraulic System Analyzer interface uses the Microsoft Human Interface Driver (HID). This driver is installed with 
Windows operating systems that support USB.

•	 The first time you connect the device to your PC, your computer automatically detects it and configures the necessary 
drivers. No third-party device drivers need to be installed.

•	 The Hydraulic System Analyzer interface is plug-and-play. You can connect it to the computer before or after you install the 
software, and without shutting off the computer.

OTE:	N Before connecting the Hydraulic System Analyzer to the computer, download and install the latest Microsoft 
Windows updates. For Windows XP, there is a Hotfix KB822603 that is installed to address a serious error within 
Windows XP and the use of USB devices.

To connect the Hydraulic System Analyzer to your computer:
1.	 Connect the USB cable to the Hydraulic System Analyzer and then plug the other end into a USB port on the computer.
2.	 The first time the Hydraulic System Analyzer is connected to the computer, several “Found New Hardware” balloons or 

dialogs pop up. This is normal.
3.	 Once the hardware has been found and installed, the last balloon or dialog states “Your new hardware is installed and 

ready to use.” At this point, the Hydraulic System Analyzer interface has been successfully installed and can be used with 
the software application.
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Software Overview

SOFTWARE OVERVIEW
The software provides a realtime graphical and digital interface for monitoring and/or recording pressure, temperature, and 
flow rate parameters from the Hydraulic System Analyzer. In addition to the graphical and digital displays, the main screen has 
a menu bar, buttons with common functions, and alarm indicators.

Figure 1:  Flo-Check USB hydraulic system analyzer screen

Measurement 
(over a 1 second time period)

Color 
Indication

Alarm 
Indication

Digital 
Indication

Graphical 
Display

Record to 
File

Average Pressure Green • • • •
Minimum Pressure Dark Green • •
Maximum Pressure Dark Green • •

Average Temperature Blue • • • •
Average Flow Rate Yellow • • • •

Average Power Orange • •
Table 6: Measurement display and record features
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Running the Software and Viewing Realtime Data

RUNNING THE SOFTWARE AND VIEWING REALTIME DATA
1.	 Connect the USB cable from the Hydraulic System Analyzer to the computer.

OTE:	N This is required before starting the software. This allows the software application to detect a connected unit.
2.	 Start the software application from the Start menu, or by double-clicking on the Flo-tech Hydraulic System Analyzer 

icon on your desktop.
3.	 Click Run.
4.	 Data on the digital displays and the strip-chart are updated once per second.
5.	 Click Stop to halt the collection of data.

RECORDING MEASUREMENTS TO A FILE
All measurements can be saved to a comma-separated value (.csv) file. This file type is a generic text file with the data 
separated by commas and can be read by many spreadsheet applications such as Excel® and Corel® Quattro Pro®. These 
spreadsheet programs can then re-graph and manipulate the data.
All measurements taken (see Table 1 on page 6) are saved once per second to the file. For example, recording for 2 minutes 
yields 120 points of data. Even though data points are only recorded once per second, pressure spikes and dips are captured 
by recording the maximum or minimum pressure during each measurement period. Therefore, the precise shape of the 
pressure spike is not recorded, but its amplitude and the time it occurred are both recorded.

Figure 2:  Example file
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Recording Measurements to a File

Recording a File
1.	 Connect the USB cable from the Hydraulic System Analyzer to the computer.

OTE:	N This is required before starting the software. This allows the software application to detect a connected unit.
2.	 Start the software application by double-clicking on the Flo-tech Hydraulic System Analyzer icon on your desktop.
3.	 Click Record.
4.	 Enter a name for the file in the filename: text box and click Save.

Figure 3:  Select location for data file

OTE:	N The default location for saving a log file for Windows XP and Windows 2000 is 
C:\Documents and Settings\<user name>\My Documents\Flo-tech\Hydraulic System Analyzer\Datalog 
The default location for saving a log file for Windows Vista® is 
C:\Users\<user name>\Documents\Flo-tech\Hydraulic System Analyzer\Datalog

OTE:	N If you wish to record over an existing file, double-click on the file from the list.
Data on the digital displays and the strip-chart is updated once per second. The message "Recording…" also displays under 
the Run button to indicate the software is in Record mode rather than Run mode. Data is not recorded if the file is already 
open by another application, such as Excel®.
5.	 Click Stop to halt the collection of data.

Recording a File While in Run Mode
1.	 Connect the USB cable from the Hydraulic System Analyzer to the computer.

OTE:	N This is required before starting the software. This allows the software application to detect a connected unit.
2.	 Start the software application by double-clicking on the Flo-tech Hydraulic System Analyzer icon on your desktop.
3.	 Select File > Record To… to open a Save As dialog form.
4.	 Enter a name for the file in the filename: text box and click Save.
5.	 Click Run to start viewing measurements.

OTE:	N The Record button is not grayed out. This is because the software filename and location have been set up before 
entering Run mode.
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Log Interval

6.	 When ready to start recording, click Record. The message "Recording…" displays under the Run button to indicate the 
software has entered Record mode.

7.	 Click Stop to halt the collection of data.
OTE:	N Once you click Stop, the Record To filename is erased from memory to avoid accidental overwriting of files. You must 

enter this information before each session when trying to record while in Run mode.

Entering Run or Record Mode
The menu disappears when entering Run or Record mode and returns when you click Stop. This blocks changes from being 
made while the software is collecting measurements. Such changes can create gaps in the collection process.
Entering the Run or Record mode also causes a blue indicator to flash in the Log Interval frame. This indicates the Hydraulic 
System Analyzer interface is running and collecting data.

Recording Modes
There are two recording modes:

•	 Record All Points

•	 Capture Points Manually 

Record All Points

The Record All Points setting records all points in one second intervals to a .csv file until you click Stop. 

Capture Points Manually

The Capture Points Manually setting lets you enter Run mode and use Record to capture points at desired intervals. 
1.	 Select Options > Record Mode > Capture Points Manually from the main menu.
2.	 A "Save Data File as…" dialog box asks you to name the file you want to create and where to save it. Type a name in the  

 filename: text box and click Save.
3.	 Click Run to start viewing measurements. Notice the Record button text has changed to Manual Capture.
4.	 Click Manual Capture. The message "Captured Point…" displays under the Run button for approximately one second to 

indicate the software has recorded one point to the .csv file.
5.	 Continue clicking Manual Capture to append more points to the .csv file.
6.	 Click Stop to halt the collection of data.

OTE:	N Unlike the Record All Points mode, clicking Stop does not erase the .csv filename from memory. Data points are 
appended to the file each time you click Stop, so there is no danger of overwriting a .csv file.

OTE:	N To capture points to a new .csv file, enter a new filename under the File > Record To… menu selection.

LOG INTERVAL
The Log Interval is used to stop the Hydraulic System Analyzer and software from running or recording data after a set period 
of time. To adjust the Log Intervall, click the Up/Down arrows next to the log time (hours and minutes) on the main screen. 
Next to the Log Interval setting is the Time Period in seconds. Since the strip-chart increments once every second, the elapsed 
time can be compared to the Log Interval in seconds. For convenience, the elapsed time is also displayed in hours and minutes 
on the lower right side of the software application.
The default Log Interval setting is 4 hours when launching the application. This is sufficient for most tests and also allows using 
the software without having to adjust the Log Interval first. If the operator doesn’t need to setup a test period and each test is 
less than 4 hours, then the Log Interval setting does not need to be adjusted and can be ignored.
Click Clear Graph to clear the graph and reset the number of measurements that are compared to the log period. For 
example, if the Log Interval is set to 4 hours and you click Clear Graph, you can run another 4 hour test before timing out. 
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Changing Measurement Units

CHANGING MEASUREMENT UNITS
Set the measurement units before entering the Run or Record modes.
1.	 Select the menu item Options.
2.	 Select Pressure, Temperature, Flow or Power units and select the desired unit.
The digital display and strip-chart legends change to the selected unit.

Pressure Temperature Flow Rate Power *
PSI °F GPM HP
Bar °C LPM kW
KPa — — —
MPa — — —

Kg/cm² — — —

* Digital Display Only
Table 7: Measurement units

USING THE GRAPH
The graph on the main screen has a strip-chart. When the software is in Run or Record mode, the strip-chart scrolls from right 
to left at a rate of 1 group of plots per second. The complete graph displays the last 60 plots (or 60 seconds) of data. Previous 
data points that scroll off the graph are saved in memory. You can view them at any time until you clear the graph or close 
the application.

Viewing Graph History
If the strip-chart contains more than 60 points of data, select the View History checkbox located on top of the upper left 
corner of the graph. Use the horizontal scroll bar below the graph to scroll through the data. The current incoming data is not 
lost while you view the history data, so you can view it while the Hydraulic System Analyzer is in Run or Record mode. When 
finished viewing the history data, un-check the View History checkbox and the graph returns to displaying the current  
realtime data.

Displaying and Hiding Individual Graph Plots
The top of the graph has a color coded legend for each plot. Next to each legend label is a checkbox that controls the 
visibility. A checked box displays the plot and an un-checked box hides the plot.

Adjusting the Graph Scales
You can adjust the scale of each plot (Pressure, Temperature and Flow Rate) independently so the plot displays over most of 
the graph height. The pressure scale is on the left side of the graph. The temperature and flow rate scales are on the right side. 
Under each scale is a left and right arrow used for scale adjustment. The left arrow decreases the scale and the right arrow 
increases the scale. You can make scale adjustments while in Run or Record mode.

Displaying Graph Gridlines
Select View > Show Graph Gridlines to display the horizontal graph gridlines.

Clearing the Graph
Click Clear Graph or select View > Clear Graph from the menu.
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Using the Alarms

USING THE ALARMS
There are three sets of High / Low alarm indicators on the main screen that monitor pressure, temperature and flow rates. The 
alarm indicators flash if the current system measurements exceed the set alarm limits. The alarms continue to flash when the 
current system measurements return back to normal to alert you that an alarm condition occurred. You must reset the alarms 
manually to acknowledge the alarm condition. Upon exiting Run or Record mode, you can view all alarm events (time, value, 
alarm level) in another form. These alarm events are also recorded to the .csv file when in Record mode.

Changing Alarm Settings
1.	 If in the Run or Record mode, click Stop.
2.	 Select View > Alarm Settings from the main menu.

Figure 4:  Alarm settings screen

3.	 Click the Up/Down arrows to adjust the level of each alarm to the desired position.
4.	 Click Exit.
The alarm level for each measurement is indicated on the strip-chart by the highlighted area shown on its associated scale. 
Any measurement taken inside the highlighted area triggers the alarm.

Resetting the Alarms
Click Reset Alarms. Alarms are reset if the alarm condition is false.
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Using the Alarms

Viewing Alarm History
1.	 If in the Run or Record mode, click Stop.
2.	 Select View > Alarm History from the main menu to display the alarm events for each measurement.

Figure 5:  Alarm History screen

3.	 Click Clear History at the bottom of the form to erase captured alarms.
4.	 Click the red X in the upper right corner to exit the form.

OTE:	N Alarm events are also recorded to the .csv file when in Record mode.
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Saving/Loading Software Configurations

SAVING/LOADING SOFTWARE CONFIGURATIONS
You can save the current software application’s settings to a configuration file that you can recall at a later time. This feature is 
useful for tests that use different measuring units and alarm settings. Rather than resetting each parameter, you can recall all 
test parameters from a file.

Saving Software Configurations
1.	 If in the Run or Record mode, click Stop.
2.	 Set all software parameters to desired settings.
3.	 Select File > Save Setup Configuration from the main menu.
4.	 A Save Data File as… dialog box asks you to name the configuration file and where to save it. Type a name in the filename: 

text box and click Save.
OTE:	N The default location for saving a configuration file for Windows XP and Windows 2000 is 

C:\Documents and Settings\<user name>\My Documents\Flo-tech\Hydraulic System Analyzer\Configurations 
The default location for saving a configuration file for Windows Vista® is 
C:\Users\<user name>\Documents\Flo-tech\Hydraulic System Analyzer\Configurations

Loading Software Configurations
1.	 If in the Run or Record mode, click Stop.
2.	 Select File > Open Setup Configuration from the main menu.
3.	 A Select Data File to Open… dialog box asks you to select the desired configuration file. Select a configuration file and 

click Open.
OTE:	N The default location of this dialog box shows files in the following folder for Windows XP and Windows 2000 is 

C:\Documents and Settings\<user name>\My Documents\Flo-tech\Hydraulic System Analyzer\Configurations 
The default location of this dialog box shows files in the following folder for Windows Vista® is 
C:\Users\<user name>\Documents\Flo-tech\Hydraulic System Analyzer\Configurations
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Calibration

CALIBRATION
The Hydraulic System Analyzer is calibrated at the factory, but you may need to reset zero for the pressure and flow rate 
sensors occasionally. Calibration parameters are stored within the electronic interface and not the PC software. When the 
software application is launched, it automatically reads the calibration parameters from the device. Therefore, owners of 
multiple units can use the same PC without worrying about calibration files.

Resetting Zero for the Pressure Transducer
1.	 Select Tools > Calibration from the main menu.

Figure 6:  Calibration screen

2.	 Select the Pressure or Flow radio button at the top of the calibration screen.
3.	 Make sure the pressure/flow of the Hydraulic System Analyzer is at zero and click Read.
4.	 If the Calibrated Value reading under the Units column is not around zero, click Set Zero to recalibrate the sensor's zero 

output and write the value to the Hydraulic System Analyzer.

Resetting Factory Calibration Defaults
Click Restore Factory Settings.
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Test Procedures

TEST PROCEDURES

WARNING

ALL TESTERS ARE SHIPPED WITH THE LOADING VALVE IN THE CLOSED POSITION. OPEN THE LOADING VALVE 
FULLY BEFORE INITIATING FLOW AND TESTING OF THE HYDRAULIC CIRCUIT. TURN THE LOADING VALVE HANDLE 
COUNTERCLOCKWISE TO THE FULLY OPEN POSITION. FAILURE TO OPEN THE LOADING VALVE FULLY CAN RESULT IN 
INJURY TO PERSONNEL AND/OR DAMAGE TO THE EQUIPMENT.

THESE UNITS ARE NOT DESIGNED FOR HIGH PRESSURE "DEADHEAD" (LOADING VALVE FULLY CLOSED) APPLICATIONS, 
IN THE REVERSE DIRECTION. USAGE UNDER THIS CONDITION COULD LEAD TO LADING VALVE FAILURE. UNDER SUCH 
CONDITIONS, MAXIMUM OPERATING PRESSURE IS LIMITED TO 2000 PSI (138 BAR).

THE INFORMATION IN THIS MANUAL IS FOR GENERAL APPLICATION ONLY. FOLLOW ANY INFORMATION FURNISHED BY 
THE MANUFACTURER OF THE MACHINE’S HYDRAULIC COMPONENTS. SPECIFIC SYSTEMS MAY REQUIRE SPECIFIC  
TEST PROCEDURES.

Standard Test Conditions
1.	 Install the Hydraulic System Analyzer as described in one of the following test procedures:

◊	 "Tee Test" on page 19

◊	 "Inline System Test" on page 20

◊	 "Control Valve and Bi-directional Hydraulic Motor Test" on page 21

◊	 "Bi-directional Cylinder Test" on page 22

◊	 "Hydrostatic Transmission Diagnostics" on page 23
2.	 Open the loading valve fully by turning the handle counterclockwise.
3.	 Start the pump and adjust it to the rated speed.
4.	 To raise the system temperature, close the tester loading valve to develop a pressure somewhat below the relief valve 

pressure. Maintain until the desired temperature is reached.
5.	 Open the Hydraulic System Analyzer’s loading valve fully and proceed with the required test procedure.
6.	 The Hydraulic System Analyzer logs flow, pressure, temperature and power readings concurrently. See 

"Recording Measurements to a File" on page 10.
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Test Procedures

Tee Test
Install a tee between the pump and control valve and connect it to the IN port of the Hydraulic System Analyzer. The OUT 
port of the Hydraulic System Analyzer is connected to the tank. Pumps and relief valves can be isolated from the system and 
checked with the Tee Test.

Flo-Check

Figure 7:  Tee test
WARNING

INCREASE PRESSURE SLOWLY. THE RELIEF VALVE MAY NOW BE ISOLATED FROM THE HYDRAULIC CIRCUIT, AND SYSTEM 
PRESSURES HIGHER THAN THE RELIEF VALVE SETTING CAN RESULT IN INJURY TO PERSONNEL AND/OR DAMAGE TO 
THE EQUIPMENT.

Pump Test

1.	 Install the Hydraulic System Analyzer in the Tee Test configuration and plug the line to the control valve.
2.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
3.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10), then close the loading valve to 

increase pressure from zero pressure to rated or maximum pump pressure to determine pump condition.
4.	 The pump flow at rated pressure can now be checked against the pump manufacturer’s specifications. A decrease in flow 

from zero pressure to maximum pressure indicates the pump condition. A pump that delivers a constant low flow at zero 
pressure and at maximum pressure suggests suction problems.

Relief Valve Test

1.	 Put a control valve into a power output mode with the output flow blocked, such as a cylinder at the end of its stroke or 
center a closed center valve.

2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Close the Hydraulic System Analyzer loading valve while recording or viewing the pressure. Pressure increases until the 

relief valve opens. Record the pressure at this point. Repeat to check the relief valve adjustment.

Relief Valve in Separate Housings

1.	 Install the Hydraulic System Analyzer in the Tee Test configuration and plug the line to the control valve.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Close the Hydraulic System Analyzer loading valve while recording or viewing the pressure and flow. Pressure increases 

until the relief valve opens. You can reference this point on the Hydraulic System Analyzer software. Repeat to check the 
relief valve adjustment.

Relief Valves

Often relief valves start to open before they reach their full pressure flow settings. This can be noted by comparing the 
pressure and flow rate readings made in a pump test. Any great decrease in flow rate from tests made in a pump test indicates 
a faulty relief valve.
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Test Procedures

Inline System Test
Virtually all system components can be unidirectionally tested or set in this configuration.

Flo-Check

Figure 8:  Inline system test

Begin by installing the Hydraulic System Analyzer between the pump and the control valves.

Pump Test

1.	 If the directional control valve's (DCV's) center does not allow an unrestricted flow path back to tank, see "Pump Test" in 
"Tee Test" on page 19.

2.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
3.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10), then close the loading valve to 

increase pressure from zero pressure to rated or maximum pump pressure to determine pump condition.
4.	 The pump flow at rated pressure can now be checked against the pump manufacturer’s specifications. A decrease in flow 

from zero pressure to maximum pressure indicates the pump condition. A pump that delivers a constant low flow at zero 
pressure and at maximum pressure suggests suction problems.

Relief Valve in Separate Housings

1.	 If the DCV's center does not allow an unrestricted flow path back to tank, see "Pump Test" in "Tee Test" on page 19.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Close the Hydraulic System Analyzer loading valve while viewing or recording the pressure and flow. Pressure increases 

until the relief valve opens. You can reference this point on the Hydraulic System Analyzer software. Repeat to check the 
relief valve adjustment.

Often relief valves start to open before they reach their full pressure flow settings. This can be noted by comparing the 
pressure and flow rate readings made in a pump test. Any great decrease in flow rate from tests made in a pump test indicates 
a faulty relief valve.
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Test Procedures

Motor Test No Load

1.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Put the motor’s control valve in the forward operating position. If there are multiple valves, only one control valve should 

be in an operating position at any one time.
4.	 Using a tachometer, run the motor with no load. The flow and RPM should match the manufacturer’s specification. A 

decrease in RPM from the manufacturer’s specifications indicates a loss of the motor’s efficiency.

Motor Test Loaded

1.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Put the motor’s control valve in the forward operating position. If there are multiple valves, only one control valve should 

be in an operating position at any one time.
4.	 Using a tachometer, run the motor while providing a load on the motor. The flow and RPM can now be checked against 

the motor manufacturer’s specifications. A decrease in RPM from the manufacturer’s specifications or the unloaded motor 
test indicates a loss of the motor’s efficiency.

Control Valve and Bi-directional Hydraulic Motor Test

Flo-Check

Figure 9:  Control Valve and Bi-directional Hydraulic Motor Test

Motor Test No Load

1.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 108).
3.	 Put one control valve in the forward operating position. If there are multiple valves, only one control valve should be in an 

operating position at any one time.
4.	 Using a tachometer, run the motor with no load. The flow and RPM should match the manufacturer’s specification. A 

decrease in RPM from the manufacturer’s specifications indicates a loss of the motor’s efficiency.
OTE:	N This test can be repeated for the reverse direction.

Motor Test Loaded

1.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Put one control valve in the forward operating position. (=If there are multiple valves, only one control valve should be in 

an operating position at any one time.
4.	 Using a tachometer, run the motor while providing a load on the motor. The flow and RPM can now be checked against 

the motor manufacturer’s specifications. A decrease in RPM from the manufacturer’s specifications or the unloaded motor 
test indicates a loss of the motor’s efficiency.
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Test Procedures

OTE:	N This test can be repeated for the reverse direction.

Motor Test Simulated Load

1.	 Reverse the pump flow.
2.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
3.	 Install one or both of the following instruments on the hydraulic motor.

a.	 Place a Hedland Variable Area Flow Meter¹ on the case drain and manually record the flow as you increase the load on 
the tester. Then compare it to the manufacturer’s specifications.

b.	 Place a tachometer on the motor’s shaft.
4.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
5.	 Increase the load on the Hydraulic System Analyzer to produce back pressure on the hydraulic motor.

WARNING

SEE MANUFACTURER'S SPECIFICATIONS FOR MAXIMUM ALLOWABLE BACK PRESSURE. IF THE MOTOR DOES NOT 
HAVE AN EXTERNAL DRAIN, IT CANNOT HAVE A BACK PRESSURE LOAD. FAILURE TO FOLLOW THE MANUFACTURER'S 
SPECIFICATIONS CAN RESULT IN INJURY TO PERSONNEL AND/OR DAMAGE TO THE EQUIPMENT.

6.	 The flow at rated RPM can now be checked against the motor manufacturer’s specifications. A decrease in RPM and an 
increase of case flow with increased load indicates a loss of the motors efficiency.

OTE:	N If the flow and RPM meet specifications, it could indicate a relief valve problem or DCV problem.
¹ For complete information, visit www.badgermeter.com and select Petroleum Fluids under Products / Variable Area High 
Pressure Flow Meters.

Directional Control Valve (DCV) Test

1.	 Isolate the motor from the circuit and connect the Hydraulic System Analyzer’s output to the DCV’s B port.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Slowly close the Hydraulic System Analyzer loading valve to achieve the rated pump pressure. Repeat for all operating 

positions of all DCV’s.

◊	 If all components are in good operating condition, pressure and flow measurements should be the same as in the 
Pump Test.

◊	 If a decrease in flow in any DCV position is noted, leakage is indicated.

◊	 If the decrease in flow is the same with the control valve in all positions, it indicates the relief valve is at fault.
OTE:	N This can also indicate some other leak is present in the control valve, such as a defective casting, damaged seals, or 

worn valve position detents, but always check the relief valve FIRST.

◊	 If the flow readings are now higher and comparable to the other control valves, then a faulty cylinder or motor 
is indicated.

Bi-directional Cylinder Test
Use this setup to calculate extension times and verify force.

Flo-Check

Figure 10:  Bi-directional cylinder test
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Test Procedures

1.	 Install the Hydraulic System Analyzer on the rod or cap side of the cylinders.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 With the load valve fully open, the extension or retraction times can be set, verified and/or logged in the circuit. Inches per 

Minute = (231 × GPM) / SQ IN.
4.	 Force can also be checked by checking the pressure when the cylinder is at the end of its stroke. 

Force = Pressure × Area

◊	 If all components are in good operating condition, pressure and flow measurements should be the same as in the 
Pump Test.

◊	 If a decrease in flow or pressure in any control valve position is noted, leakage is indicated.

◊	 If the decrease in flow is the same with the control valve(s) in all positions, it indicates the relief valve is at fault.
OTE:	N This can also indicate some other leak is present in the control valve, such as a defective casting, damaged seals, or 

worn valve position detents, but always check the relief valve FIRST.

◊	 If the relief valve is operating normally, see Directional Control valve (DCV) Test.

◊	 A decrease in pressure at the cylinders full stroke could indicate worn piston seals.

Hydrostatic Transmission Diagnostics
Install the Hydraulic System Analyzer into the system between the pump discharge port and the inlet of the hydraulic motor.

PV

Flow (Bi-directional)
Reservoir

Case Drain

MF

Flo-Check

Figure 11:  Hydrostatic transmission test
Pump

1.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10), then close the loading valve to 

increase pressure from zero pressure to rated or maximum pump pressure to determine pump condition.
3.	 The pump flow at rated pressure can now be checked against the pump manufacturer’s specifications. A decrease in flow 

from zero pressure to maximum pressure indicates a drop in volumetric efficiency.

Motor Test No Load

1.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Put one control valve in the forward operating position. If there are multiple valves, only one control valve should be in an 

operating position at any one time.
4.	 Using a tachometer, run the motor with no load. The flow and RPM should match the manufacturer’s specification. A 

decrease in RPM from the manufacturer's specifications indicates a loss of the motor's efficiency.
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Test Procedures

Motor Test Loaded

1.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
2.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
3.	 Put one control valve in the forward operating position. If there are multiple valves, only one control valve should be in an 

operating position at any one time.
4.	 Using a tachometer, run the motor while providing a load on the motor. The flow and RPM can now be checked against 

the motor manufacturer’s specifications. A decrease in RPM in the manufacturer's specifications or the unloaded motor 
test indicates a loss of the motor's efficiency.

Motor Test Simulated Load

1.	 Reverse the pump flow.
2.	 Open the Hydraulic System Analyzer loading valve fully to read maximum pump flow at zero pressure.
3.	 Install one or both of the following instruments on the hydraulic motor.

a.	 Place a Hedland variable area meter on the case drain and manually record the flow as you increase the load on the 
tester. Then compare it to the manufacturer's specifications.

b.	 Place a tachometer on the motor's shaft.
4.	 Select Run and/or Record on the PC (see "Recording Measurements to a File" on page 10).
5.	 Increase the load on the Hydraulic System Analyzer to produce back pressure on the hydraulic motor.

WARNING

SEE MANUFACTURER'S SPECIFICATIONS FOR MAXIMUM ALLOWABLE BACK PRESSURE. IF THE MOTOR DOES NOT 
HAVE AN EXTERNAL DRAIN, IT CANNOT HAVE A BACK PRESSURE LOAD. FAILURE TO FOLLOW THE MANUFACTURER'S 
SPECIFICATIONS CAN RESULT IN INJURY TO PERSONNEL AND/OR DAMAGE TO THE EQUIPMENT.

6.	 The flow at rated RPM can now be checked against the motor manufacturer’s specifications. A decrease in RPM and an 
increase of case flow with increased load indicates a loss of the motor's efficiency.

OTE:	N If the motor does not have a case drain, it cannot be loaded on the discharge side.

Other Test Procedures

Case Drain

You can check the case drain flow concurrently with any of these setups using a second Hedland Variable Area Flow Meter¹. 
However the motor’s case drain, the pump’s case drain, and the charge pump are all connected in series. This means that the 
charge pump flow must be factored into the case flow. Any increase in case flow would indicate a pump or motor problem.

Test Stand Calibration System

You can add the Hydraulic System Analyzer to any existing test stand for diagnostics calibration, certification and data logging 
of hydraulic components. You can use the Hydraulic System Analyzer for recording bi-directional flow, which makes it ideal for 
hydraulic motors and cylinders. Install the meter either on the supply or the return line of the test bench. However, place the 
meter on the supply side in case any contamination is passed through the units under test. Once the data is recorded it can be 
stored for future reference or printed and sent with the repaired unit.

Servo Controlled Pumps, Motors and Valves

Special procedures for testing these components may be specified. Observe the nstructions of the component and 
machine manufacturer.
These components may have the capability of nearly instantaneous increases of flow and/or pressure and should have a 
positive means of control. An example of such a control is the push-pull servo control for varying pump delivery. Attempting 
to manually adjust this control can result in excessive increases in flow and/or pressure. Such uncontrolled changes may cause 
a failure in the system and result in component damage or personal injury.
¹ For complete information, visit www.badgermeter.com and select Petroleum Fluids under Products / Variable Area High 
Pressure Flow Meters.
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Maintenance / Troubleshooting

MAINTENANCE / TROUBLESHOOTING
The Flo-Check USB Hydraulic System Analyzer is designed to give years of trouble-free service. However, if trouble is 
suspected, a few simple checks can be made.

PC Connectivity
If there are connection issues with newer versions of Windows:
1.	 Make sure the unit and PC are connected with a USB A/B cable.
2.	 Check the cable for any signs of damage and replace, if damaged.
3.	 Restart the PC with the unit connected to it.
4.	 Run the application in Compatibility Mode. To do this, right-click on the software icon and click Properties. Under the 

Compatibility tab, check the box for Run the program as an administrator under the Privilege Level category.
OTE:	N If step 4 does not work, check the box for Run this program in compatibility mode for: under Compatibility Mode. 

Using the activated drop-down menu, select the version of Windows that applies to your PC configuration.

Load Valve
If the valve fails to load the system, remove the valve body and check for foreign material, worn parts or seals.

Flow
The absence of any flow reading may indicate a blockage of the turbine. 
1.	 Remove the retaining ring from the inlet port and carefully remove the turbine assembly. Remove any material that may 

be preventing easy rotation of the rotor.
2.	 Reassemble and attempt a flow reading again. 
3.	 If the tester still fails to indicate flow, return the tester to the factory. For return procedures, see 

"Return Goods Authorization" on page 27.

Burst Discs
The burst discs are designed to rupture at a specified pressure. Testers provide protection from excessive pressure in either 
direction (7500 PSI differential) with two internal burst discs that, when ruptured, bypass flow around the loading valve. If 
rupture occurs, replace the burst discs.

WARNING

IF YOU DO NOT HAVE THE PROPER TOOLS TO ACCOMPLISH THIS TASK, RETURN THE TESTER(S) TO THE FACTORY FOR 
REPLACEMENT OF THE BURST DISC HOUSING AND THE BURST DISCS. INJURY TO PERSONNEL AND/OR DAMAGE TO 
EQUIPMENT MAY RESULT IF THE BURST DISCS ARE INSTALLED IMPROPERLY.

Gather the following tools and parts:

•	 5/8 in. open-end box wrench

•	 ≥ 0…50 pound-inch torque wrench

•	 Burst disc housing

◊	 Housing; F5144 (1 each)
◊	 Ring support; F6567 (1 each)
◊	 O-ring, 2-015; F3137-015 (1 each)
◊	 Backup O-ring, 2-015; F1015-015 (1 each)

•	 Burst discs

◊	 F1614-7500 (2 each)
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Dimensions

Internal Burst Disc Procedure

1.	 Position the Hydraulic System Analyzer to expose the internal burst disc housing as shown in Figure 12.

Figure 12:  Burst disc replacement

2.	 Remove the burst disc housing from the block using a 5/ in. open-end box wrench.
3.	 Remove the ruptured burst discs from the burst disc housing.
4.	 Insert one new burst disc (F1614-7500) into the housing followed by the ring support and then the second burst disc.
5.	 Verify that the burst discs are seated. Be careful not to scratch the surface of the discs.
6.	 Insert the burst disc housing with the O-ring and backup O-ring into the port of the block and hand tighten. If required, 

use a new burst disc housing.
7.	 Set the torque wrench to 40 foot-pounds (50.8 N-m).
8.	 Torque the burst disc housing into the block. Torque to 40 foot-pounds (50.8 N-m).

DO NOT OVER TORQUE THE BURST DISC HOUSING. APPLYING TOO MUCH TORQUE WILL DAMAGE THE BURST DISC 
AND CAUSE THE DISC TO RUPTURE PREMATURELY.

DIMENSIONS

D

H

L

®

Figure 13:  Dimensions
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Flow vs Pressure Drop Charts, ∆P Captured Using Loading Valves

Series
Dimensions (L x D x H) Weight

lbs (kg)in. mm
F7164 11.41 × 5.70 × 7.93 289.81 × 144.78 × 201.42 17 (7.71)
F7160 11.41 × 5.70 × 7.93 289.81 × 144.78 × 201.42 17 (7.71)
F7161 12.10 × 6.20 × 7.93 307.34 × 157.48 × 201.42 20 (9.07)
F7165 11.41 × 5.70 × 7.93 289.81 × 144.78 × 201.42 17 (7.71)
F7162 11.41 × 5.70 × 7.93 289.81 × 144.78 × 201.42 17 (7.71)
F7163 12.10 × 6.20 × 7.93 307.34 × 157.48 × 201.42 20 (9.07)

FLOW VS PRESSURE DROP CHARTS, ∆P CAPTURED USING  
LOADING VALVES
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Figure 14:  Flow vs pressure drop

OTE:	N For Flow vs Pressure Drop information on the F7164 and F7165 models, please contact the factory.

RETURN GOODS AUTHORIZATION

When returning equipment for service, a Returned Goods Authorization (RGA) number must be obtained from our Customer 
Service Department. Please contact them by phone at 877-243-1010.
All returns go to the following address and must include the RGA number on the outside of the box:
Badger Meter, Inc.
8635 Washington Avenue
Racine, WI 53406-3738 USA
Attn: RGA # xxx-xxxx

WASTE ELECTRICAL AND ELECTRONIC EQUIPMENT (WEEE) DIRECTIVE
In the European Union, this label indicates that this product should not be disposed of with household 
waste. It should be deposited at an appropriate facility to enable recovery and recycling.
For information on how to recycle this product responsibly in your country, please visit  
www.badgermeter.com.
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Flo-tech is a registered trademark of Badger Meter, Inc. Other trademarks appearing in this document are the property of their respective entities. Due to continuous research, 
product improvements and enhancements, Badger Meter reserves the right to change product or system specifications without notice, except to the extent an outstanding 
contractual obligation exists. © 2022 Badger Meter, Inc. All rights reserved. 
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